6.2 to 6.2a with slicer failed

3 posts / 0 new
Last post
6.2 to 6.2a with slicer failed

Hello,

 

I just used the slicer to upgrade from 6.2 to 6.2a and it all looked like it went ok but after the reboot I have lost network connectivity.

 Here are the results from the slice upgrade and any help to get the unit back on the network would be much appreciated.

Thanks

 -----------------------------------------------------------------------------

The Slicer - Version 1.4

WARNING!! We are about to install 6.2a-01-2-351 software on your TiVo
Once you start this process, there is no way to restore your
previous software version without re-imaging. Before you begin,
we suggest you make a backup image of your hard drive, and read
the forums at www.tivocommunity.com and dvrplayground.com that
pertain to The Slicer.

Hit <enter> to continue, or <cntrl-c> to exit:
Great! Here we go...

Your root filesystem partition is hda4
Your kernel partition is hda3
Your alternate root filesystem partition is hda7
Your alternate kernel partition is hda6

6.2a-01-2-351 software slices are correctly loaded and ready to install.
Hit <enter> to continue, or <cntrl-c> to exit:

 

 

Checking your system for required utilities...
find is present
wget is present
tar is present
sed is present
cut is present
All required binaries are present. Proceeding...

Editing installSw.itcl

Installing new software. This will take several minutes...

installSw.itcl ran successfully, and set up your new partitions.
Please note the following:
Your new root filesystem partition is 7
Your new kernel partition is 6

Hit <enter> to continue, or <cntrl-c> to exit:
Copying your hacked kernel to the new boot partition...
2048+0 records in
2048+0 records out
kernel copied successfully!

Mounting your new root filesystem /dev/hda7 now...
New filesystem mounted successfully!

Creating dummy iptables...
Copying your existing hacks to the new root partition...

Copying author file...
Copying Tivowebplus from /ptvupgrade/tivowebplus
Copying your ptvupgrade directory
Copying the contents of /var/hack
Copying your init directory from /init
Copying your profile from /.profile
Copying /var/spool
Copying /test.conf
Copying files from /gotomydvr
Copying all files in root non-recursively

IMPORTANT!! Please review the above list of hacks that were
copied to your new root partition. If you have any hacks that
were not copied, you must copy them manually to the
corresponding location in the /install directory before rebooting
Hit <enter> to continue:

6.2a-01-2-351 installation is complete!!

Hit <enter> to reboot your TiVo and start using your new software,
or hit <cntrl-c> to exit and check things out first.

 

More info..

More info..

 

Sorry, I didn't mention it in my first post but this is a hughes dvr40 with a pvnet instantcake 120gig harddrive that I had done myself. It was working great too.

I connected the serial cable and rebooted and this is the info that was sent to the terminal but once it booted I still had no bash prompt.

 ------------------------------------------------------------

 

Scan /mnt/opt
Scan /mnt/opt/tivo
Scan /mnt/sbin
Scan /mnt/tvbin
Scan /mnt/tvlib
Scan /mnt/tvlib/data
Scan /mnt/tvlib/data/apg
Scan /mnt/tvlib/data/dishpointing
Scan /mnt/tvlib/firmware
Scan /mnt/tvlib/firmware/prism2
Scan /mnt/tvlib/idl
Scan /mnt/tvlib/itcl
Scan /mnt/tvlib/misc
Scan /mnt/tvlib/modem
Scan /mnt/tvlib/modem/patches
Scan /mnt/tvlib/modem/patches/P2107-V90
Scan /mnt/tvlib/modem/patches/P2107-V90/ram
Scan /mnt/tvlib/modem/patches/P2109-V90
Scan /mnt/tvlib/modem/patches/P2109-V90/ram
Scan /mnt/tvlib/modem/patches/Si2433
Scan /mnt/tvlib/modem/patches/Si2433/C
Scan /mnt/tvlib/modem/patches/Si2433/C/AT
Scan /mnt/tvlib/modem/patches/Si2434
Scan /mnt/tvlib/modem/patches/Si2434/B
Scan /mnt/tvlib/modem/patches/Si2434/B/AT
Scan /mnt/tvlib/modem/patches/Si2456
Scan /mnt/tvlib/modem/patches/Si2456/D
Scan /mnt/tvlib/modem/patches/Si2456/D/AT
Scan /mnt/tvlib/modem/utils
Scan /mnt/tvlib/tcl
Scan /mnt/tvlib/tcl/apg
Scan /mnt/tvlib/tcl/tv
The filesystem seems to be OK
Scanner main is done
VFS: Mounted root (ext2 filesystem) readonly.
Trying to move old root to /initrd ... okay
Freeing unused kernel memory: 64k freed
Starting rc.sysinit
Running boot Stage A_PreKickstart scripts
Scanning for configuration files
Invoking startup scripts for:
    platform 'trinity'
    implementation 'Series2'
    implementer 'TiVo'
Releasing /initrd and clearing ramdisk, if they exist
warning: can't open /var/mtab: No such file or directory
Activating swap partitions
Adding Swap: 130044k swap-space (priority -1)
Loading core system drivers
Parallel modem driver loaded, 1 ports starting at /dev/ttyS1
Loading ircatch
Found rev 'F' Si2433 modem on /dev/cua1
Checking for Kickstart panic signal
Running boot Stage B_PostKickstart scripts
Cleanup /dev/hda9 pass 1
ext2fs_check_if_mount: No such file or directory while determining whether /dev/hda9 is mounted.
/dev/hda9 was not cleanly unmounted, check forced.
Inode 6160, i_blocks wrong 922 (counted=908).  Set i_blocks to counted? yes

Inode 6170, i_blocks wrong 6570 (counted=6562).  Set i_blocks to counted? yes

Inode 6169, i_blocks wrong 948 (counted=942).  Set i_blocks to counted? yes

Inode 6165, i_blocks wrong 268 (counted=264).  Set i_blocks to counted? yes

Inode 6146, i_blocks wrong 6356 (counted=6342).  Set i_blocks to counted? yes

Fix summary information? yes

/dev/hda9: 681/32768 files (13.5% non-contiguous), 27706/131072 blocks
Cleanup /dev/hda9 pass 2
ext2fs_check_if_mount: No such file or directory while determining whether /dev/hda9 is mounted.
/dev/hda9: clean, 681/32768 files, 27706/131072 blocks
/dev/hda9 is clean after pass 2
Mounting /var
/dev/hda9 on /var type ext2 (rw)
Cleaning up files in /var
Checking space in /var
Mounting initial environment
Starting logging daemons
Found Silicon Labs "Si2433" modem, rev F, skipping modem patch
Scanning for phase1 repair scripts
Running boot Stage C_MediaInitialization scripts
Loading input section drivers
cobra module was successfully installed, LNBPA 0x10 LNBPB 0x16
Loading output section drivers
Splash the screen
Running boot Stage D_PreMfs scripts
Remote control is  TIVO
MFS partition on  /dev/hda10
Loading Trinity dssapp
Look for debug board
/tvbin/dssappAV: DSS Interface Version 1.24, compiled on Nov 12 2004
Loading irblast
Loading ideturbo
Loading fan
Loading therm
Loading TvBus router
Updating system clock
Time set to: Sun Mar 11 01:52:44 2007
Enabling local route
Setting TCP keepalive parameters
Checking for additional disk
Start fan control
First temperature parameters set:
  Terminal temp: 71
  Critical temp: 62
  Logging temp: 60
  Target temp: 50
  Lowest fan speed: 7
/tvbin/fancontrol is running in the background.
Starting TvLauncher
PokeFirewallPort: Poking hole through firewall at port 2191, protocol tcp
Waiting for launcher to start.
Launcher is running.
Scanning for phase2 repair scripts
Running boot Stage E_PreApplication scripts
Checking for database conversions
No upgrade to load
NewSoftware: getting SwSystem name
NewSoftware: SwSystem 6.2-01-2-351 is already active.
Scanning for phase3 repair scripts
Running boot Stage F_ApplicationLaunch scripts
Starting Services.
Microcode version is TiVo!
Found hpk front panel model 1
usb.c: USB device 2 (vend/prod 0x13b1/0x18) is not claimed by any active driver.
PokeFirewallPort: Poking hole through firewall at port 2190, protocol udp
PokeFirewallPort: Poking hole through firewall at port 2190, protocol tcp
using driver frame iter
ApgLogFrequency( 0 sec )
Finished creating ApgDriverFrameIter
Using a smartSorter!
Calling ReadStream()s
....started status session
Initialize with 2 live caches
AddInputSection 1
AddInputSection 2
TvMomMediaSwitchSource::DoSetup()
TvMomMediaSwitchSource::DoSetup()
AddInputSection 3
ApgManager Transition from state INIT to BOOT
....sending Booting event
....started status session
Scanning for phase4 repair scripts
Running boot Stage G_PostApplication scripts
rc.sysinit is complete
ApgManager Transition from state BOOT to FAST_LOAD
ApgManager Transition from state FAST_LOAD to FAST_LOAD
ApgManager Transition from state FAST_LOAD to FAST_LOAD
ApgManager Transition from state FAST_LOAD to FAST_LOAD
ApgManager Transition from state FAST_LOAD to FAST_LOAD
ApgManager Transition from state FAST_LOAD to FAST_LOAD
ApgManager Transition from state FAST_LOAD to STEADY_STATE
....sending Done event
....sending Done event

 

--------------------------------------------------------- HELP......

After reading some threads I

After reading some threads I tried forcing a phone call and now it is showing the correct version number in the system information via the menus but I am still not able to connect via the network. I do have a serial calbe although I didn't have any luck getting to a bash prompt as shown in the post above but I haven't tried it since I forced the phone call. I am prepared to remove the drive or do whatever is needed to get the unit back in order but I am not sure what I need to do. I am very disappointed that the slicer did not work as it was suppose to or if it did there is something missing from the instructions that I am missing.