SVR-3000... 250Gb Drive... Can't quite get there...

cj415's picture
Forums: 

I am having trouble completing my large drive upgrade on my SVR-3000. I can't get all of the 250Gb drive to be recognized.

Here are the steps I've taken so far.

1. Purchased a new 250Gb Western Digital Drive

2. Installed InstantCake for the SVR-3000. This installed the 4.0.1 image onto the drive. I had to use IC because the original drive was completely dead.

3. Updated the drive to 7.2.2-oth1 by installing the drive back into the SVR-3000. The drive all tested fine as an 80Gb drive.

4. I put the drive back in the PC, and booted with a non-LBA48 boot disk. I made a backup of the drive by using Hinsdale's instructions...

mfsbackup  -f 9999 
-6so  /mnt/dos/tivo.bak  /dev/hdc

5. I then restored the image to test it..

mfsrestore -s 127 -bzpi /mnt/dos/tivo.bak /dev/hdc. No problems.

6. I then booted the PTV Ultimate Boot Disk 11 into LBA48 mode.

7. I restored my backup once again in this LBA48 environment.

8. I tested the disk. No problems (still being seen by SVR-3000 as 80Gb).

9. I tried to add space using...

mfsadd -x /dev/hdc

but I got errors about invalid drive headers.

 

I have tried all sorts of other combinations. I tried doing everything in a non-LBA48 environment and I got to the standard 137Gb limit.

I tried restoring under a non-LBA48 environemnt, and then switched to LBA48 to do only the mfsadd, but no luck. I also tried expanding the drive to 137Gb, and then expanding the drive again in LBA48. The drive expanded both times, but failed to boot once back in the TiVo.

I am tempted to try doing a PTVbake-special, but I'm stuck on that, too. I'm thinking that I need modify the PTVbake-special script to find the 7.2.2 image that is sitting on my hda (C:) drive.

Any suggestions.This must be possible. Thanks.